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最佳实践
 
  
电商压测场景示例
 
 
性能压测最终的目标是模拟真实的业务场景，通常业务场景是复杂多变的。在使用 PTS 进行压测前，您需要对
业务场景进行梳理，可参考性能测试技术指南的具体指导。然后，将业务场景编排为实际可用的压测场景，在
PTS 中发起压测。
 
下面以电商典型业务场景为例，为您介绍如何在 PTS 中编排压测场景。
  
什么是压测场景？
 
要发起一次性能压测，首先需要创建一个压测场景。压测场景中包含一个或多个并行的业务，每个业务包含一
个或多个串行的请求。
  
示例
 
淘宝网需要对产品 A 和 B 相关的页面（即存在多个 API）进行压测，假设其主要业务场景为：
 

 
业务 A：浏览产品 A
 
 
业务 B：购买产品 B（登录 → 浏览产品 B → 加入购物车 → 提交订单）
 
 

那么在压测场景中的设置如下。
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说明如下：
 

 
串联链路1：浏览产品A 和 串联链路2：购买产品B 是并行关系。
  
根据业务逻辑，一部分用户在浏览产品 A，另一部分用户在进行购买产品 B 的一系列操作，即两个业
务是同时发生的，所以将它们设置为两个串联链路，压测中会并行发起请求。
 
 
串联链路中的多个 API 是串行关系。
  
根据业务逻辑，串联链路2：购买产品B 中的一系列用户行为是存在先后顺序的，所以将这些存在先后
关系的 API 添加到一个串联链路中，压测中会按照顺序发起压测。
 
 
综合起来看，在压测中，示例中的 浏览产品A API 和 登录 API，会同时发起压测流量。
 
  

后续操作
 
串联链路编排完成后，您可以进行施压配置，为整个场景和每一个串联链路设置压测量级。
 
 
 
在线教育压测示例
 
 
下面以在线教育的典型业务场景为例，为您介绍如何在 PTS 中编排压测场景并发起压测。
 
要发起一次性能压测，首先需要创建一个压测场景。压测场景中包含一个或多个并行的业务，每个业务包含一
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个或多个串行的请求。
  
场景说明
 
某在线教育网站需要压测选课相关网页。根据业务逻辑，选课流程划分为三步，每一步的压测需求如下：
 

 
登录在线教育系统
 

需要构造用户的登录信息，如用户名和密码；
用户的登录信息（即 Cookie），需要传递给后面两个请求：查看课程列表和提交选课。

 
查看课程列表
 

将“课程 ID”传递给提交选课请求。
 
提交选课
 

使用上一个请求中的“课程ID”，构造提交选课的请求。
判断提交选课是否成功。

 
那么基本压测场景设置如下。
 

  
场景配置操作步骤
 
关于如何实现以上压测需求，参照以下步骤。
 

 
登录 PTS 控制台。
 
 
在左侧导航栏单击创建压测 > 快速压测。
 
 
在创建压测页面，填写场景名称，例如“在线教育示例”。
 
 
在场景配置页签下，填写压测 API 名称、URL 地址，并选择请求方法。示例如下：
 

 
API 名称：登录在线教育系统
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压测 URL 地址：http://www.example.com/mocks/online/login
 
 
请求方法：POST
  
说明：该示例中，使用的域名“www.example.com” ，均为示例地址，压测中不产生真
实请求。您可以根据真实业务场景填写压测 URL，或者在域名绑定页签下，为该域名绑定
有效的 IP 地址，产生真实请求流量。
  

 
 
为模拟不同用户登录，需要使用文件参数构造用户登录信息，步骤如下：
 

 
在本地准备参数文件：新建一个 .csv 文件（用 Excel 编辑之后另存为 .csv 格式，或者用
Apache 的 commons-csv 来生成），构造两列数据，分别对应用户名和密码，示例如下
：
  

 
 
在创建场景页面右上角，单击全局自定义参数，单击上传文件，将本地准备的参数文件上
传到该场景中。
 
 
填写参数名，例如 “username” 和 “passwd”。
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选择 Body 定义页签，选择 Body 类型并使用用户登录信息，定义该压测 API 的 Body 内容。
  
例如，Body 是 JSON 格式，则 Content-Type 选为 raw，在右侧下拉框中选择 JSON
(application/json)。
  
Body 正文定义为：
 

 
如图所示：
  

  
说明：Body 正文中的 ${username} 和 ${passwd}，为用户登录参数。您可以通过页面右上角的参
数列表，快速查看并复制。
  
当前请求的 Cookie 信息（即用户登录信息），将自动共享给该压测场景的其他 API，无需设置。
 
 
单击 +添加压测 API，填写第二个 API 的信息。示例如下：
 

API 名称：查看课程列表
压测 URL 地址： http://www.example.com/mocks/online/list
请求方法：POST

{
"username": "${username}",
"password": "${passwd}"
}
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为了将某个“课程 ID” 传递给下一个请求，需要提取当前 API 响应（Response）中的“课程
ID”，作为出参。
  
选择出参/断言定义页签，填写信息：
 

出参名：填写自定义的参数名称；
来源：选择 Body 的解析格式，如 JSON；
 
解析表达式：根据 Response 详情填写解析表达式。
  
假设，要提取第二个课程 ID，则根据以下 Response Body 示例，解析表达式为
：schedule_list[1].ID
 

 
说明：出参的解析表达式如何定义，是否正确，可以在调试功能里使用表达式调试的功能
，正确之后再同步过来即可，详见本文的 场景调试操作步骤。
 

 
如图所示：
  

 
 
单击 +添加压测 API，填写第三个 API 的信息。示例如下：
 

API 名称：提交选课
压测 URL 地址： http://www.example.com/mocks/online/submit

{
"schedule_list": [
{
"Name": "math",
"ID": "001"
},
{
"Name": "english",
"ID": "002"
},
{
"Name": "science",
"ID": "003"
}
]
}
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请求方法：POST
 
选择 Body 定义页签，在 Body 中使用前一个 API 导出的出参参数“课程 ID”。
 

Content-Type：选择 x-www-form-urlencode 格式。
Key：填写自定义的 Key。
Value：单击页面右上角的参数列表，查看串联链路参数（如“ID”），单击可复制。在
Value 框中粘贴即可。

 
如图所示：
  

 
 
为判断“提交选课”是否成功，为该 API 设置断言。
 

 
选择出参/断言定义页签，填写信息：
 

出参名：填写自定义的参数名称；
来源：选择 Body 的解析格式，如 TEXT；
 
解析表达式：根据 Response 详情填写解析表达式；
  
假设，示例中的 Response Body 如下，则解析表达式为：result:(.+)，注意
：来源要选择 Body 的解析格式为TEXT，同样的，您也可以在场景调试中使用
表达式调试的功能调试您的解析表达式；
 

勾选设为断言，在断言区域，选择等于，并填写对应的信息，如“success”。
 
如图所示：
  

result:success
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施压配置操作步骤
 
基本场景构建完成后，需要选择施压模式、设置施压量级等。
 

 
选择施压配置页签，填写信息，示例如下：
 

压测来源：选择国内公网；如果您在阿里云内网环境，可选择阿里云内网。
压测模式：选择并发模式，以虚拟用户模式发起压测，更适合客户端发起的场景；而 RPS
模式是站在服务端的视角，衡量系统吞吐量。
是否自动递增：关闭自动递增。
最大并发：并发模式下，需要填写最大并发用户数，如 10。
压测总时长：例如，填写 10 分钟。

 
其他可保留默认值。如图所示：
  

 
 
单击创建场景页面右上角保存配置。
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场景调试操作步骤
 

 
单击创建场景页面右上角调试场景。一般调试时间在10秒至30秒。
  
调试结束后，可以查看所有 API 的调试详情。具体可参见场景调试。
 
 
选择“查看课程列表” API，单击点此去测试出参正则表达式。
  

 
 
选择来源，填写正则表达式，单击测试表达式，可验证提取的内容是否符合预期。
  

  
您也可以单击同步出参配置，将此处的表达式同步为出参。
 
  

启动压测
 
单击保存去压测，即可发起压测。
 
更多信息，请参见以下文档：
 

压测中调速
压测报告
出参与断言
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如何进行 WebSocket 协议的压测
 
 
通过 Apache JMeter 和对应的插件编写脚本，并在 PTS 中上传这些脚本、插件 JAR 包和其他相关文件，即可
发起压测。本文以 JMeter WebSocket Samplers 插件为例，主要介绍如何在本地使用 Apache JMeter 编写
、调试压测脚本，以实现 WebSocket 协议的业务场景压测。
  
背景信息
 
目前 PTS 原生压测模式不支持压测 WebSocket 协议的业务场景，例如 binary 的数据发送等场景。可以通过
Jmeter 类型压测来实现。
 
WebSocket 的插件较多，本文仅以 JMeter WebSocket Samplers 为例。JMeter WebSocket Samplers 具
有以下特性：
 

提供了六种 WebSocket Sampler，这些 Sampler 不会新建额外的线程，节省资源。
支持 WSS（WebSocket over TLS）。
JMeter 的 SSLManager 能设置 WSS，包括客户端证书。
支持二进制的 WebSocket 数据帧。
支持二进制响应的断言。
View Results Tree 里可以查看二进制结果。
支持使用 JMeter 的 Header Manager 设置 WebScoket Upgrade Request 上额外的 HTTP
Header。
支持使用 JMeter 的 Cookie Manager 设置升级协议的请求里的 Cookie。
支持代理。
支持过滤数据帧。
 

关于本文没有涉及的代理、过滤、分片等信息，详见 JMeter WebSocket Samplers 插件介绍。
 
操作步骤如下：
 

步骤一：安装插件 JMeter WebSocket Samplers
步骤二：创建脚本
步骤三：运行脚本
步骤四：导出脚本
步骤五：上传脚本、插件 JAR 包或其他文件至 PTS 进行压测
  

步骤一：安装插件 JMeter WebSocket Samplers
 

 
下载 JMeter WebSocket Samplers，建议下载最新版本。
 
 
将下载的插件 .jar 包存放在 <JMeter安装目录>/lib/ext 路径下。
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注意：在 PTS 中发起压测时，此处下载的插件 .jar 包需要上传到 PTS。详见步骤五。
 
 
重启 JMeter。
  
重启 JMeter 之后，按照以下步骤查看插件是否安装成功：
 

 
右键单击左侧导航树中的 Test Plan，选择 Add > Config Element，可看到新增的配件元
件选项 WebSocket Binary Frame Filter、WebSocket Ping/Pong Frame Filter 和 
WebSocket Text Frame Filter 。
  

 
 
右键单击左侧导航树中的 Test Plan，选择 Add > Assertions，可看到新增的断言选项 
Binary Response Assertion。
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右键单击左侧导航树中的 Test Plan，选择 Add > listener > View Results Tree，在编辑
页面左下方的下拉列表中，可看到新增的选项 Binary。
  

 
 
右键单击左侧导航树中的 Test Plan，选择 Add > Threads(Users) > Thread Group，右
键单击 Thread Group，选择 Add > Sampler，可看到以下新增的采样器选项，具体说明
如下。
 

Sampler 名称 说明

性能测试 PTS 最佳实践
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下一步，需要配置这些 Sampler。
 

  
步骤二：创建脚本
 
下面将演示如何在测试场景中添加并配置 Sampler。以下为简单示例，您可以根据业务需要进行调整。
 

 
在 Jmeter 页面中，右键单击 Test Plan，选择 Add > Thread (Users) > Thread Group， 将一个
线程组添加到测试计划中。
 
 
在线程组中依次添加采样器（Sampler），并进行配置。右键单击 Thread Group，选择 Add >
Sampler > WebSocket Open Connection。当前的 Sampler 将建立 WebSocket 连接。
  

  
说明：我们以 Gateway Echo 服务来创建脚本（wss://echo.websocket.org） 。这是一个 Echo 服
务，因此发送到此服务的所有消息都将回显给客户端。
  
相关的配置如下：
 

WebSocket Open Connection 建立一个 WebSocket 连接

WebSocket Ping/Pong 控制帧，发送 ping 并接收 pong

WebSocket request-response
Sampler

发送和接收文本或二进制 WebSocket
帧

WebSocket Single Write Sampler 发送文本或二进制 WebSocket 帧

WebSocket Single Read Sampler 接收文本或二进制 WebSocket 帧

WebSocket Close 关闭 Websocket 连接

配置项 示例值 说明

协议 WS

协议可以是 WS 或
WSS（Secure
WebSocket）。使用 WSS
进行加密连接。

Server name or IP echo.websocket.org 域名 或 IP

Port 443 端口

Path - 可为空

Connection 20000 建连的超时时间
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右键单击 Thread Group，选择 Add > Sampler > WebSocket Ping/Pong。该 Sampler 用来测试
Ping/Pong 功能。
  

  
相关配置如下：
 

 
Pong（读）超时（ms）：6000
  
Pong（读）超时表示如果 JMeter 在 6 秒内没有收到 Pong 消息，则 Sampler 将失效。
此 Sampler 会复用已有连接。
 

 
右键单击 Thread Group，选择 Add > Sampler > WebSocket request-response Sampler。该
Sampler 将发送文本的一个数据帧并从服务端接收应答。
  

  
相关配置如下：
 

timeout（ms）

Read timeout（ms） 6000 等待服务器响应的超时时间

配置项 示例值 说明

Connection use existing connection 创建新的连接或复用已有连
接。

数据类型 文本 指定数据类型、请求数据和
响应超时值。

Request data PTS 请求数据，这里以文本为例

Response（read）timeout
（ms） 6000 响应超时时间
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右键单击 Thread Group，选择 Add > Sampler > WebSocket Single Write Sampler。此请求是
非阻塞的，只是将数据发送到服务端不需要等待响应。
  

  
相关配置如下：
 

 
右键单击 Thread Group，选择 Add > Sampler > WebSocket Single Read Sampler。接收服务
端的消息响应需要使用这个 Sampler。
  

  
相关配置如下：
 

配置项 示例值 说明

Connection use existing connection 创建新的连接或复用已有连
接

数据类型 文本 指定数据类型、请求数据和
响应超时值

Request data PTS 请求数据，这里以文本为例

Response（read）timeout
（ms） 6000 响应超时时间

配置项 示例值 说明

Connection use existing connection 创建新的连接或复用已有连
接

数据类型 文本 指定数据类型、请求数据和
响应超时值

性能测试 PTS 最佳实践
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右键单击 Thread Group，选择 Add > Sampler > WebSocket Close。接收服务端的消息响应需
要使用这个 Sampler。
  

  
相关配置如下：
 

此采样器将关闭现有的 WebSocket 连接，由于是协商关闭，显示原因为 “1000：sampler
requested close”。
 
 
右键单击 Thread Group，选择 Add > Listener > View Results Tree，在线程组中添加监听器 
View Results Tree。接收服务端的消息响应需要使用这个 Sampler。
 
  

步骤三：运行脚本
 
脚本编辑完成后，单击页面顶部的开始按钮，运行脚本。
 
通过 View Results Tree 监听器查看脚本是否运行正常。在左侧导航树中，选择View Results Tree，检查所有
Sampler 是否都配置正确并符合预期。在该监听器中，如果 Sampler 前面有绿色对勾表示运行正常。
 
如出现运行异常的 Sampler，请参照步骤二进行调试。
 
部分示例结果如下：
 

 
WebSocket request-response Sampler
  
根据脚本配置，Request 信息如下：
  

Response（read）timeout
（ms） 6000 响应超时时间

配置项 示例值 说明

Close Status 二进制 关闭连接时定义的状态码
，数据帧的头两个字节

Response（read）timeout
（ms） 6000 响应超时时间

性能测试 PTS 最佳实践
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根据脚本配置，Binary 格式的 Response data 如下：
  

 
 
WebSocket Single Read Sampler
  
根据脚本配置，Text 格式的 Response data 如下：
  

  
根据脚本配置，Binary 格式的 Response data 如下：
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步骤四：导出脚本
 
当本地脚本调试成功后，选择顶部菜单栏的 File > Save Test Plan as，将脚本文件保存至本地。  
步骤五：上传脚本、插件 JAR 包和其他文件至 PTS 进行压测
 
您需准备以下文件，上传到 PTS：
 

导出的 JMeter 脚本（.jmx 文件）
JMeter WebSocket Samplers 的 JAR 包
脚本中使用的其他数据文件
 

关于在 PTS 中压测的操作步骤，详见 JMeter 原生压测。
 
 
 
如何进行 TCP 协议的压测
 
 
如果您需要对 TCP 协议的场景进行压测，您可以使用 JMeter 的 TCP Sampler 来编写脚本，然后将脚本文件
上传至 PTS 发起压测。
  
JMeter 操作步骤
 

 
启动 JMeter GUI。
 
 
为 JMeter 测试计划添加 TCP Sampler Config，定义脚本中所有 TCP Sampler 的共用参数。
 

 
右键单击测试计划，选择 Add > Config Element > TCP Sampler Config。
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在 TCP Sampler Config 中，填写 TCP Sampler 的共用参数，例如 Server Name or IP
和 Port Number。
  

 
 
为 JMeter 测试计划添加一个线程组，为线程组添加一个 TCP Sampler。
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19



-

-

-

 
 
设置 TCP Client classname，以 TCPClientImpl 为例。
  
说明：
  
JMeter 中 TCP Sampler 可以通过三种方式实现，主要区别为内容的编码格式不同：
 

TCPClientImpl（默认的 TCP Sampler）：发送内容为编辑器中的纯文本；
BinaryTCPClientImpl：发送的内容是二进制字节（由编辑器中的十六进制字符转换而来
）；
LengthPrefixedBinaryTCPClientImpl：在 BinaryTCPClientImpl 基础上，在发送内容上
增加前缀。此前缀表示发送内容的长度。

 
根据您的实际压测需求，配置其他选项。
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配置说明如下：
 

超时（毫秒）： 
Connect timeout：建立连接的超时时间，单位是毫秒；
Response timeout：等待响应的超时时间，单位是毫秒；

Re-use connection：是否复用前置 session 的连接；
Close connection：每次发送新数据之前，是否断开当前连接并新建连接；
Set NoDelay：勾选此项，消息将以独立的包发送；不勾选此项，较小的消息会合并在一
个包中发送。
SO_LINGER：用于设置延迟关闭的时间，等待套接字发送缓冲区中的数据发送完成。未选
中时，在关闭连接发送完FIN后会立即进行一些清理工作并返回。如果勾选了
SO_LINGER选项，并且设置了值，则在清理之前会等待一段时间；
EOL：设定来自于服务器数据流的一个结束标识字节，如果没有设置则会一直读到输入流结
束；
Text to send：填入纯文本的发送内容。

 
说明：
 

BinaryTCPClientImpl 和 LengthPrefixedBinaryTCPClientImpl 的配置与 TCPClientImpl
类似。区别是 BinaryTCPClientImpl 和 LengthPrefixedBinaryTCPClientImpl 的 Text to
send 框中需要输入十六进制编码格式的内容，最终发送的内容为二进制数据。
您也可以基于 TCPClientImpl 定义自己的实现方式，并将其放在上述的 TCP Sampler 的
TCPClient classname 中。

 
其他常见配置，例如预处理、后置处理、正则表达式提取和断言组件，同样可结合 TCP Sampler 使
用。
 
 
根据您的压测需要，参照上述步骤，配置多个线程或多个 TCP Sampler。
 
进行脚本调试，调试成功后，保存 .jmx 脚本文件。
  

PTS 操作步骤
 
将 .jmx 脚本、JAR 文件（如有）、CSV（如有）上传到 PTS，设置压测量级，即可随时发起压测。
 
详见 JMeter 原生压测。
 
 
 
JMeter 模拟上传
 
 
如果需要对文件、图片的上传接口进行压测，您可以使用 JMeter 编写脚本，模拟上传功能，然后通过 PTS 的
JMeter 原生压测方式发起压测。
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本文为您介绍如何使用 JMeter 客户端构造场景，生成压测脚本。
  
前提条件
 

本地安装 JMeter 客户端
  

操作步骤
 
以下步骤将介绍如何编写 JMeter 脚本模拟上传功能。
 

 
启动 JMeter 客户端。
 
 
右键单击 Test Plan，选择 Add > Threads(Users) > Thread Group，为 JMeter 测试计划添加线
程组，示例命名为“模拟上传”。
 
 
右键单击 Thread Group，选择 Add > Sampler > HTTP Request，在线程组中添加 HTTP 请求
，示例命名为“上传”。
 
 
根据业务实际接口，填写 HTTP Request Basic 页签下的基本信息。示例如下：
 

Protocol：http
Server name or IP：www.example.com
Port Number：8080
Method：POST
Path：/fileupload

 
【注意，此处必选】勾选 Use multipart/form-data。
 
 
在 Parameters 页签下，单击 Add，添加请求 Body 中的参数信息。一般上传接口中无需填写，视
具体请求来配置。配置项说明如下：
 

配置项 说明 示例值

Name 参数名 /

Value 参数值 /

URL Encode? 是否进行 encode 编码 选中后会进行 encode 编码
，默认不选中。

Content-Type 内容类型 text/plain。

Include Equals 无 Value 值的参数是否需要
等号（=）

选中之后 URL 会变为
http://www.example.org?l
ogin= ，此为规范的 URL
写法。
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选择 Files Upload 页签，单击 Add，添加参数信息。
 

配置完成后，如下图：
  

 
 
右键单击 HTTP Request Sampler “上传”，选择 Add >Config Element > HTTP Header
Manager，添加 Header 信息。上传接口一般需要配置 Cookie 和 Content-Type。如果 Thread
Group 中有登录操作，可不单独设置 Cookie。
  
配置示例如下：
  

 
 
右键单击 Thread Group “模拟上传”，选择 Add > Listener > View Results Tree，在线程组中
查看结果树。
 
 
保存测试计划文件，进行脚本调试。
  
根据 View Result Tree 查看该上传脚本的请求信息，示例如下：
  

配置项 说明 示例值

File Path 文件路径

填写文件名。注意：将该脚
本上传至 PTS 发起压测时
，需直接填写文件名，勿添
加本地地址。

Parameter Name 参数值 file

MIME Type 内容类型 image/png
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后续操作
 
调试成功后，将该测试脚本及相关文件上传至 PTS 进行压测。详见 JMeter 原生压测。
 
 
 
如何使用参数化模拟多用户注册或登录
 
 
若您需要压测的业务中包括用户登录 / 注册的场景，可以借助 PTS 提供的文件参数功能，模拟不同用户的登录
/ 注册的压测场景。本文将以对用户注册界面发起压测为例，介绍如何使用文件参数来构造动态变化的请求
URL。
  
背景信息
 
在网站注册页面，通常需要用户提供用户名和密码，如下图所示。若您在压测时需要模拟多用户注册的场景
，可以通过在压测场景中导入包含用户名和密码的参数文件，构造压测 API 时关联导入的参数来实现。
 
关于登录场景的 PTS 支持能力的信息，详情请参见登录（Cookie）的支持。
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在网站登录页面，通常还需要输入验证码。若您在压测时需要模拟多用户登录的场景，您可以业务代码中配置
一个万能验证码，并且在 PTS 配置 API 时带上万能验证码，然后通过在压测场景中导入包含用户名和密码的参
数文件，构造压测 API 时关联导入的参数来实现。
  
步骤一：准备参数文件
 

 
下载参数文件示例至本地，或者在本地用excel编辑好之后另存为 .csv 格式的文件（或者可以用
Apache 的 commons-csv 来生成），构造两列数据，分别对应用户名和密码，如图所示：
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说明：此文件中仅有 10 行数据，这些数据可以在压测中循环使用或仅使用一次。您也可以准备更多
行数据，构造更多用户的登录/注册请求。
 
  

步骤二：创建压测场景
 

 
登录 PTS 控制台，在概览页单击快速压测，或者在左侧导航栏单击创建压测 > 快速压测。
 
 
在创建压测页面，填写以下：
 

场景名：压测用户注册页面
压测 API 名称：用户注册

 
如图所示：
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步骤三：导入参数文件
 

 
在创建压测页面右上角，单击全局自定义参数。
 
 
在文件参数定义部分，点击+上传文件，将本地的参数文件导入 PTS。
 
 
文件导入后，系统自动根据文件中的两列生成参数列表。您需要手动填入参数名，例如
“username” 和 “password”。单击确定，关闭对话框。
  

  
单击创建压测页面右上角的参数列表，查看已创建的文件参数，如图所示：
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1.

 
  

步骤四：填写压测 URL 和 Body
 

在创建压测页面，填写压测 URL，例如 http://www.example.com/register 。
 
选择请求方式为 POST。
  

 
 
选择 Body定义 页签，单击 Body 编辑区域右上角的文本编辑，在文本编辑框中输入
user_name=${username}&user_pwd=${password}&code=common_code。
  

  
说明：
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Body 中使用的用户名参数为 ${username}，密码参数为 ${password}。
  
打开参数列表，单击参数名 username 或 password 可复制参数内容，编写 Body 内容时
，直接粘贴即可。
 
在用户注册场景中，通常您需要在业务代码中设置一个万能验证码。以上图为例
，common_code 是万能验证码。

 
返回当前 API 的基本请求信息页签，勾选数据轮询一次，能够保证在使用数据文件组装请求时，每
一行只用到一次，避免重复登录。当数据轮询一次用尽，不论设置的压测量级是多少，该压测场景将
停止生成新的压测请求。
  
如不勾选数据轮询一次，导入的参数可以在压测中循环使用。
  

 
  

步骤五：配置压力并启动压测
 

 
在创建压测页面，选择施压配置页签，填写最大并发数值（10），其他可保留默认配置。
  

 
 
单击右上角保存去压测，启动压测。
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PTS + ARMS 典型应用
 
 
本文通过介绍 PTS 与 ARMS 产品组合的典型应用场景，帮助您了解 PTS 与 ARMS 组合在性能测试方面定位问
题和剖析问题的能力。
  
背景介绍
 
服务端的性能测试，特别是业务性能测试，目的主要是性能容量评估、性能瓶颈诊断、应用错误诊断，甚至是
验证高可用的能力，从而通过针对性的优化达到降低成本、提升用户体验的目的。而施压侧的监控以及服务端
的基础监控主要用于发现问题和做初步定位，当需要进一步定位和剖析问题时会显得有点捉襟见肘。
 
因此，PTS 通过集成 ARMS 监控的能力来提升这方面的能力，通过将关键的服务端性能指标整合到压测整体监
控中，达到更快和更便捷地识别问题的目的。
  
产品组合
 

 
性能测试 PTS（Performance Testing Service）
  
简单直接的云化性能测试工具，孵化自阿里全链路压测平台。互联网化的交互，适合更多的用户，轻
松模拟大量用户访问业务的场景，所需资源随时发起，免去搭建和维护成本，高效、低成本、精准衡
量业务能力。近期也发布了ARMS监控集成的功能。
 
 
业务实时监控服务 (Application Real-Time Monitoring Service，简称 ARMS)
  
一款 APM 类的全链路 (Tracing) 监控产品。用户可基于 ARMS 的前端、应用、自定义监控，快速构
建实时的业务监控能力。
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适用行业
 
PTS + ARMS 组成的压测监控方案，除了在阿里内部淘宝和天猫等电商领域有着大量实践以外，截止目前为止
在各大行业都有着大量的案例实践。其覆盖行业包括：电子商务、互联网金融、游戏行业、新媒体行业和其他
大型政央企行业案例。覆盖场景包括新版本性能基线测试、大促场景测试、线上容量规划等。
 

  
典型场景介绍
 
以下对各个常用场景进行介绍。
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性能容量评估
 

 
诉求：
  
以某知名在线教育平台为例，希望以最小的成本应对常态化的选课高峰，保证峰值情况下的用户体验
不能下降。
 
 
分析：
  
根据木桶原理，木桶最短的板也就是容量最小的系统决定了站点的能力。用户需要做的是识别短板
，通过调整长短板之间的机器配比达到拉平系统水位的目的，那么即使是同样数量的机器也可以提供
更大的业务吞吐量，甚至不用额外扩容。
  
通过 PTS + 集成云监控和 ARMS 监控的一站式服务，不仅可以有效判断特定配置系统下的系统性能
容量，同时能有效判断出现性能瓶颈时的配置短板，如系统性能、数据库瓶颈、代码问题等，从而为
最有效的优化性能容量提供有效基础数据。
 
 
容量评估 3 步骤
 
 
 
使用 PTS 快速构建高仿真业务压测。
  

 
 
通过 PTS 控制台一站式观察压测发起侧（客户侧）及服务侧（云监控）的端到端全监控，了解高压
下的业务表现和各核心系统的性能水位情况。
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再通过 ARMS 集成快速找到应用瓶颈点，列出接口快照，结合系统性能诊断慢快照具体耗时原因
，如系统性能、慢SQL或其他代码问题。
  

 
  

性能瓶颈诊断
 
除了调整容量配比以外，通过探测和识别系统瓶颈点，并进行针对性优化进而提升站点性能的方式可以进一步
提升同样机器数量情况下的整体容量水位。
 

 
诉求：
  
以在线教育平台上通过浏览器登录选课为例，最常见的一个操作流程如下。通过压测，识别到系统中
的瓶颈。
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分析：
  
以上流程是有严格的先后顺序的，是一个事务，在 PTS 中就是一个串联链路。借助 PTS 对登录
Cookie 的友好支持，整个链路都可以通过 PTS 简单配置出对应的压力测试流量，并通过 ARMS 进行
监控，从而观察分析性能瓶颈。
  
通过 PTS + ARMS 不仅可以有效分析出现性能瓶颈时的，还能通过 PTS 发现接口调用性能瓶颈拐点
，并一键跳转到 ARMS中通过具体线程剖析发现具体代码栈内的性能瓶颈拐点，从而为优化代码性能
提供代码栈级别的证据。
 
 
性能瓶颈诊断 3 步骤：
 
 
 
使用 PTS 快速构建压测并一站式观察相关应用的接口调用耗时，寻找性能瓶颈点。
  

 
 
使用 ARMS 观察应用对应接口的耗时，并找到对应的慢接口调用的线程剖析。
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通过线程剖析找到对应接口的线程快照，分析性能瓶颈。
  

 
  

应用错误诊断
 
除了容量评估、性能瓶颈诊断以外，如何在压测场景下有效进行错误诊断也是企业级互联网应用正式上线前的
一大场景。这类错误虽然一般不会直接影响调用耗时从而造成性能瓶颈，但是仍然会由于业务错误引发糟糕的
用户体验。
 
一般在基线性能下，除了耗时以外，应用一般还可能被返回各类调用错误，典型的有：
 

超时错误 (timeout)：当后端服务来不及响应时，可能会在客户端造成 timeout 错误。
熔断错误：该类错误最主要被各类熔断组件触发 (如 sentinal)，保护后端应用性能。
其他系统组件引起的错误：典型的如性能超载引起的 IOException 等。
 

通过 PTS + ARMS 可以在压力增加时，有效发现应用系统因压力过大引起的各类错误（如上所述）。通过 PTS
的施压侧监控和多维度监控，不仅可以有效发现业务接口错误，还可以通过 ARMS 集成关联到具体的错误异常
详情，定位到具体错误抛出的详细代码，从而指数级提高压测场景下的接口错误诊断效率。
 
错误接口诊断 3 步骤：
 

 
使用 PTS 观察压测增加时是否发生业务异常/错误。
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使用 ARMS 观察对应应用的总体错误调用，判断问题点。
  

 
 
打开错误的异常详情，通过异常的快照详情判断分析错误的根本原因。
  

 
  

快速接入
 

 
了解 PTS 产品详情
  
具体操作，参见文档：开通服务、进行压测场景创建并压测、云监控集成、ARMS 监控集成
 
 
了解 ARMS 产品详情
  
具体操作，参见文档： 开通服务、快速接入
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PTS 和 AHAS 共同保障应用稳定性
 
 
本文通过介绍性能测试 PTS 与 AHAS 流控降级产品组合的典型应用场景，帮助您了解 AHAS 流控降级功能是
如何保障应用稳定性的。
  
背景信息
 
服务端的性能测试，特别是业务性能测试，目的主要是评估性能容量、诊断性能瓶颈、诊断应用错误，以及验
证高可用的能力，通过针对性的优化达到降低成本、提升用户体验和系统可用性的目的。
 
而在评估出系统容量后，您通常需要根据系统可承载的极限，设置对应的限流阈值，以防突发的流量洪峰超出
系统可承载的最大值而引发雪崩效应。AHAS 流控降级模块能够从流量控制（限流）、熔断降级、系统保护等
多个维度保障服务的稳定性。
  
产品组合
 

 
性能测试 PTS（Performance Testing Service）
  
PTS 是一款简单直接的云化性能测试工具，孵化自阿里全链路压测平台。互联网化的交互适合更多的
用户，PTS 能够轻松模拟大量用户访问业务的场景，随时发起所需流量，免去搭建和维护成本，具备
高效、低成本、精准衡量业务的能力。
 
 
应用高可用服务 AHAS（Application High Availability Service）
  
AHAS 流控降级模块，由阿里巴巴内部的限流产品 Sentinel 演化升级而来，支持了天猫双 11、双 12
及年货年等大促活动，是一款面向分布式服务架构的专业流量控制组件。AHAS 流控降级主要以流量
为切入点，从流量控制（限流）、熔断降级、系统保护等多个维度保障服务的稳定性，同时提供强大
的聚合监控和历史监控查询功能。目前客户端支持 Java 语言。
  
和常见的网关限流相比，AHAS 流控降级有以下优势：
 

 
精细的防护粒度
  
支持自定义接口资源，可以根据 QPS、线程、系统负载等多种指标进行限流或者降级。
 
 
全方位的监控
  
支持查看接口的实时、历史监控数据，以更加友好的界面展现当前资源通过的 QPS、拒绝
的 QPS、RT 等信息，同时支持查看单机指定资源的监控数据。
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多种主流框架适配
  
提供 Web servlet、Dubbo、Spring Boot/Spring Cloud、gRPC、Apache RocketMQ、
Netflix Zuul 等多种框架的适配，只需要引入相应的依赖并进行少量配置即可接入。
 
 
良好的性能
  
客户端的性能损耗非常小。只有在单机业务量级超过 25 万 QPS 的时候才会有一些显著的
影响（10% 左右），单机 QPS 不大时损耗几乎可以忽略不计，详见 Sentinel 性能测试报
告。
 

  
适用行业
 
PTS 与 AHAS 共同组成的压测流控方案，不仅在阿里内部淘宝、天猫等电商领域有着广泛的应用，在互联网金
融、游戏行业、直播行业和其他大型政央企行业也有着大量的实践。通过 PTS 进行系统验证，提早发现性能短
板的同时，通过 AHAS 进行流量防控，进一步确保系统的稳定性。
  
最佳实践
 
下面简要介绍如何通过 PTS 和 AHAS 进行流量防控。
 

根据您的业务场景，通过 PTS 构建高仿真业务压测，验证系统能够支持的最大并发请求量。
 
压测停止后，在压测报告中可查看当前系统的最大并发请求量。
  

 
 
假设某重要接口经过多次优化和压测后达到了业务预期的 QPS，系统机器资源也是按照该访问量配
置的。如果用户请求超过该预期值，可能会导致 CPU、负载飚高，随之引发一系列问题影响正常用
户访问。
  
那么，我们就需要通过 AHAS 流控降级功能对该接口资源设置相应的流控规则，将限流阈值设置为
期望限制的 QPS 值。
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默认情况下，新建的流控或降级规则立即生效。在 AHAS 流控降级监控页面，您可以实时查看该接
口资源的通过的 QPS 和拒绝的 QPS。
  

  
这样就能保证系统一直处于期望的安全水位之内，即使出现突发的流量，也不用担心资源耗尽被拖垮
。
 
  

相关文档
 

关于 AHAS 流控降级的接入和使用，请参考开通 AHAS 服务、接入和规则配置。
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使用 PTS 监测日常业务
 
 
随着移动互联网的继续普及，业务连续性的要求越来越高，如何先于用户发现不同地域或者运营商网络下的核
心功能可用性问题是所有移动互联网场景下的业务都需要思考或者解决的问题，有别于普通的拨测，我们更需
要一种动态API的监控方式，而且是基于特定业务含义场景下的API的监控（如登录、一些具体的业务行为
），结合不同地域和运营商的边缘计算的节点算力去探测全国范围甚至是全球范围内的核心动态业务的可用性
和性能。
 
本文以典型的电商业务为例：每天 20:00 发起一次探测为例（实际可以设置更高的频率），指定压测流量来源
为华北区域，一旦压测中请求成功率低于 100% 即停止压测，PTS会通过钉钉机器人通知进而可以进行异常排
查。
  
背景信息
 
典型的电商核心业务场景一般包括以下流程：登录 > 查看类目商品列表 > 查看子商品信息 > 添加购物车 >确
认订单，前后 API 之间可传递参数。
 
对于电商中的核心业务，需每天监测，保证业务表现正常，如出现失败，可及时排查。
  
操作流程
 
该示例中涉及的主要操作流程如下：
 

 
步骤一：创建压测场景
  
根据业务模型构建压测场景，该示例中将使用电商典型场景，并在 API 之间进行参数传递。
 
 
步骤二：配置压测量级并指定地域
  
根据业务压测需要设置，该示例中将设置每个接口 1 RPS，同时指定流量设置为华北区域。
  
说明：根据运营商和地域设置压测流量的来源，是可选步骤，您可以根据自己的业务需要选择是否使
用，不指定则PTS会随机调度全国范围内的节点。
 
 
步骤三：设置 SLA
  
根据业务要求设置 SLA 监控指标和规则，该示例中将设置请求成功率低于 100% 时即停止压测，出
现异常就需要人为介入排查问题。该示例中的 SLA 比较严格，适用于核心业务。
 
 
步骤四：设置定时任务
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i.

ii.

iii.

该示例中将设置每天执行一次压测任务。定时压测任务设置成功后，PTS 将定时自动发起压测。
 
  

步骤一：创建压测场景
 
根据业务模型构建压测场景，该示例中将使用电商典型场景，并在 API 之间进行参数传递。
 

 
登录 PTS 控制台，在左侧导航栏选择创建压测 > 快速压测。
 
 
在创建压测页面，填写场景名称。
 
 
为该场景准备文件参数，具体步骤参见创建文件参数。
  
该示例中导入了两个参数文件，共定义了 3 个参数，分别是 itemID_global、username、
password，如下图所示：
  

 
 
在创建压测页面，编排业务接口（API）。
  
该示例为电商业务，共编排了五个业务接口（API）：登录、查看类目商品列表、查看子商品信息、
添加购物车、选做_确认订单。并设置了 API 之间的参数传递。
  
具体步骤如下：
 

 
填写第一个 API：登录的基本请求信息。
 

压测 URL：输入具体的业务接口。
请求方式：POST
数据轮询一次：选择该选项，表示该接口的文件参数数据只轮询一次。例如
，用户数据的文件参数有 1000 行，则压测轮询一次 1000 个用户数据后就会停
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ii.

止压测。
 

 
 
在登录接口的 Body 中定义用户名和密码，使用已导入的文件参数 username 和
password。
  
根据业务需要，也可以在 Body 中定义其他内容，如下图中的 signon 即自定义的 Body
内容。
  

 
 
填写第二个 API：查看类目商品列表的基本请求信息。
 

压测 URL：输入具体的业务接口。
请求方式：GET

 
选择出参/断言定义，提取 productId 作为出参，传递给下一个 API。示例如下：
  

 
 
填写第三个 API：查看子商品信息的基本请求信息，并在其 URL 中带入上一个 API 提出
的参数 productId。
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选择查看子商品信息的出参/断言定义页签，提取出参 itemID。
  

 
 
填写第四个 API：添加购物车的基本请求信息，并在其 URL 中带入上一个 API 提出的参
数 itemID。
  

 
 
选择添加购物车的出参/断言定义页签，提取出参 prod_item_Id_check，并设置为断言
：product ID 小于 1000 时该业务断言成功，否则为失败。
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填写第五个 API：选做_确认订单的基本请求信息。
 

 
场景创建成功后，如下图所示：
  

 
  

步骤二：配置压测量级并指定地域
 
由于是业务监测，该示例中将每个接口设置1的起步RPS，同时指定流量按照比例来自是华北地域。
 
具体步骤如下：
 

在创建压测页面，选择施压配置页签，选择 国内公网 和 RPS模式 设置各接口API的最大RPS为10即
可，起步都设置为 1 RPS，压测时长 1 分钟即可，如图所示：
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选择流量定制（指定地域、运营商来源），单击详细配置，指定压测来源为华北地区 100%。如图所
示：
 

  
步骤三：设置 SLA
 
根据业务要求设置 SLA 监控指标和规则，该示例中将设置请求成功率低于 100% 时即停止压测，出现异常就需
要人为介入排查问题。
 
具体步骤如下：
 

在创建压测页面，选择SLA定义页签，单击创建SLA，填写 SLA 名称、选择业务分类。
 
在SLA规则下方单击 +添加规则，在添加SLA规则窗口中设置成功率低于 100% 时停止压测，如图所
示：
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返回创建 SLA 页面，保持 SLA 的适用对象为空，即该规则适用于全部 API。
  

 
 
在高级配置区域，选择停止压测的联系人，选择钉钉作为通知方式，如图所示：
  

  
说明：需提前创建联系人，具体步骤参见管理接收人。
 
  

步骤四：设置定时任务
 
该示例中将设置每天执行一次压测任务。定时压测任务设置成功后，PTS 将定时自动发起压测。
 
具体步骤如下：
 

 
在创建压测页面右上角，单击场景调试。定时任务的前提是压测能够顺利执行，所以设置定时任务前
，需进行场景调试。
  
稍等数秒后，查看场景调试页面，API 响应符合预期即表示成功。
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单击创建压测页面右上角的保存去压测，执行周期选择定时压测。配置其他项：
 

执行频率：选择定期执行，在时间窗口中选择 20:00，并在日粒度下选择全部。您可以在当
前页面预览最近五次压测的时间。
执行通知方式：压测开始前通知
通知对象及通知方式：选择已创建的联系人，并通过钉钉通知。

 
如图所示：
  

 
 
单击确定，完成创建。
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在指定日期和时间，系统将自动发起压测。
  
每次压测时的请求正确率不足 100% 时，钉钉将收到压测已停止的通知，可能就代表业务有异常了
，需要及时排查跟进。
 
 

  
小程序压测示例
 
 
不同于网页压测，针对小程序压测时，通常需要获得小程序所在的平台（如微信）的 Token 信息，并在有效期
内使用，才能正常压测小程序业务接口。
 
推荐您通过以下两种方式获取平台授权 Token：
 

 
编写接口自动获取 Token，并在有效期内刷新该 Token。压测中，您通过 PTS 压测该接口，可以自
动获得 Token。
 
 
压测前提前记录平台 Token，并以参数形式传入小程序业务接口中。但是，请注意压测时长不能超过
Token 的有效期，避免因 Token 失效导致无法进行业务压测。
 
 

本文以微信平台为例，介绍如何压测微信平台上的小程序。
  
方式一：编写接口获取 Token
 
假设需要压测微信平台上小程序的活动页面。那么，您可以编写接口去获取微信的 Token 信息，将该接口编排
进压测场景中，并提取出参，传递给后面实际的业务接口。
 
具体操作步骤如下：
 

 
在本地编写接口，以便能够在压测过程中持续地获取微信的 Token 信息。
 
 
登录 PTS 控制台，在左侧导航栏选择创建压测 > 快速压测。
 
 
在创建压测页面，填写场景名称，例如“myAPP”。
 
 
在场景配置页签下，填写第一个压测 API，即自定义的获取微信 Token 的接口。
 
 
选择出参/断言定义页签，配置示例如下：
 

出参名：access_token
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来源：Body：JSON
解析表达式：access_token

 

 
 
单击+添加压测 API，填写第二个 API，即小程序活动页面接口，请求方式选择为 POST。
 
 
单击创建压测页面右上角的参数列表，并单击出参名，复制该出参参数。
  

 
 
假设需要在 API 的 Body 中传入已复制的出参 access_token，单击 API 的 Body定义页签。在 Key
中填写自定义的名称（例如 input_token），在 Value 中粘贴已复制的出参参数。
  

 
 
选择施压配置页签，根据实际需要，填写压测并发数和时长等信息。示例如下图所示：
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说明：施压配置的更多信息，参见如何进行施压配置。
 
 
单击创建压测页面右上角的保存去压测，即可发起压测。
 
  

方式二：手动记录 Token 并写入业务接口
 
假设需要压测微信平台上小程序的活动页面。那么，您可以在压测前提前批量获取到平台 Token，或者在本地
准备些数据（如果业务允许），放在数据文件中，压测时作为全局参数使用。
 
注意：一般平台 Token 都存在有效期限制，需要定期刷新才能使用。所以，采用该方法请注意确认 Token 有
效期，超过该期限后，压测就无法正常进行。
 
具体操作步骤如下：
 

 
新建一个 .csv 文件（用 Excel 编辑之后另存为 .csv 格式，或者用 Apache 的 commons-csv 来生成
），将 Token 信息写在一列中，示例如下：
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说明：您可以通过线上环境批量获取平台 Token，或者如果业务允许的情况下可在本地构造 Token
数据。
 
 
登录 PTS 控制台，在左侧导航栏单击创建压测 > 快速压测。
 
 
在创建压测页面，填写场景名称，例如“myAPP”。
 
 
在场景配置页签下，填写小程序活动页面接口。
 
 
单击创建压测页面右上角的全局自定义参数，单击上传文件，上传本地准备的 .csv 文件。上传完毕
后，填写参数名，并单击确定。
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单击创建压测页面右上角的参数列表，并单击全局参数名，复制该参数。
  

 
 
假设需要在 API 的 Body 中传入已复制参数，单击 API 的 Body定义页签。在 Key 中填写自定义的
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名称（例如 token），在 Value 中粘贴已复制的出参参数。
  

 
 
选择施压配置页签，根据实际需要，填写压测并发数和时长等信息。示例如下图所示：
  

 
单击创建压测页面右上角的保存去压测，即可发起压测。
 

  
实现无人值守压测
 
 
除了立即启动压测，您也可以创建定时压测任务，同时结合 SLA 指标，对压测中业务的表现进行监控，一旦不
满足指标要求，立即停止压测，或触发告警。
 
这一系列过程都可以在 PTS 中自动化实现，实现无人值守的压测。
  
示例场景
 
假设某公司需要在每月 5 号 20:00 进行压测，同时需要业务的响应时间 （RT）保证在 550 ms 以下，否则就
停止压测并给负责人发出通知。
  
前提条件
 
已创建告警接收人。参见管理接收人。
  
步骤一：创建压测场景
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根据实际业务流程，将业务接口（即 API）编排在 PTS 压测场景中。步骤如下：
 

 
登录 PTS 控制台，在左侧导航栏单击创建压测 > 快速压测。
 
 
在创建压测页面，填写场景名称，并编排业务接口。示例如下：
  

 
 
选择施压配置页签，根据实际需要，填写压测并发数和时长等信息。示例如下：
  

 
  

步骤二：设置 SLA 监控指标
 
完成业务压测 API 编排和施压配置后，可为这些 API 指定监控指标，即业务的 SLA。步骤如下：
 

 
选择 SLA定义 页签，单击创建 SLA。
  
说明：您也可以从左侧导航栏选择 SLA管理 前往单独的页面创建 SLA （具体步骤参见创建 SLA
），然后在 SLA 定义页签下选择导入已有 SLA。
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本示例中，假设业务的响应时间 （RT）需保证在 550 ms 以下，否则就停止压测并给负责人发出通
知。
  
则总体配置如下：
  

  
说明：告警接收人需提前创建，具体步骤参见管理接收人。
  
其中，在 SLA规则区域框中，单击 +添加规则，进行 SLA 规则的配置。示例如下：
  

 
  

步骤三：调试压测场景
 
定时任务的前提是压测能够顺利执行，所以设置定时任务前，需进行场景调试。
 
在创建压测页面右上角，单击场景调试。稍等数秒后，查看场景调试页面，API 响应符合预期即表示成功。
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步骤四：设置定时任务
 
压测场景创建并调试完成后，可以指定测试任务的执行日期、执行时间、循环周期和通知方式等，从而实现定
时压测。
 
假设某公司需要在每月 5 号 20:00 进行压测，步骤如下：
 

 
单击创建压测页面右上角的保存去压测，执行周期选择定时压测。
 
 
配置其他项，示例如下：
 

执行频率：选择定期执行，并在日粒度下选择 5 号。您可以在当前页面预览最近五次压测
的时间。
执行通知方式：压测开始前通知
通知对象及通知方式：选择已创建的联系人，并通过钉钉通知。

 
如图所示：
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单击确定，完成创建。
  
在指定日期和时间时，系统将自动发起压测。
 

 
压测前，您设置的钉钉会收到如下通知：
  

 
 
压测开始后，在控制台概览页下方的压测场景列表中，可以看到正在执行的压测。单击查
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看图标，进入压测中页面。
 
 
压测时，如果本示例中的 API 的 RT 超过 550 ms，该压测将自动停止，并通知联系人。
 
 
压测后，与所有压测相同，您可以查看压测报告，分析问题并做相应的性能优化。
 

  
更多信息
 

创建 SLA
配置场景 SLA
管理接收人
定时压测
 

  
使用场景模板压测
 
 
PTS 控制台设有登录场景和秒杀场景模板，您可以借助模板快速完成压测。本文以秒杀场景模板为例介绍如何
使用场景模板进行压测。
  
背景信息
 
PTS 提供的秒杀场景模板中模拟了 10000 个不同用户名和密码的用户同时登录页面，然后进行秒杀加购 > 商
品购买 > 支付订单系列操作的场景。模板中的所有配置为总结各秒杀业务场景的经验所得，您可按需修改。
  
操作步骤
 

 
登录 PTS 控制台，在概览页单击快速压测，或者在左侧导航栏单击创建压测。
 
 
在创建压测页面单机选择场景模板 > 秒杀场景。
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在场景配置页签进行以下操作：
 

 
将各 API 的 URL 替换成您的业务 API URL。
 
 
在前置串联链路（全场景）中将数据配置节点配置为您的真实业务数据，参见数据配置节
点。
 

 
单击施压配置页签，在施压配置页签中按需修改施压配置，参见如何进行施压配置。
 
 
单击域名绑定页签，按需绑定您的域名，参见绑定域名。
 
 
在页面右上角单击场景调试，在场景调试对话框中进行场景调试，参见场景调试。
 
 
在页面右上角单击保存去压测 > 立即压测。
  
说明：压测过程中可针对 API、串联链路或全局维度进行调速，参见启动压测并调速。
 
  

后续操作
 
压测完成后，需要查看压测报告来分析本次压测结果。如何查看压测报告请参见压测报告。
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